Slower load times observed on various pages

Incident Report for Wiz

Resolved

This incident has been resolved.
Posted Apr 04, 2025 - 08:28 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 04, 2025 - 07:14 UTC

Investigating

We are currently investigating this issue.
Posted Apr 04, 2025 - 06:24 UTC
This incident affected: Portal.