We are continuing to monitor closely and will provide another update once full recovery is confirmed.
Posted Oct 20, 2025 - 12:26 UTC
Update
We continue to see improvements across our services as AWS recovers from the US-East-1 incident. Our systems are steadily returning to normal operation, though some residual impact may remain. We are continuing to monitor closely and will provide another update once full recovery is confirmed.
Posted Oct 20, 2025 - 12:09 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 11:25 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 09:54 UTC
Monitoring
We are seeing signs of recovery from the ongoing AWS incident impacting the US-East-1 region. We will continue to monitor the situation closely and provide an update once full recovery is confirmed. For more details from AWS, visit https://health.aws.amazon.com/.
Posted Oct 20, 2025 - 09:36 UTC
Update
Last update from AWS: [02:01 AM PDT] We have identified a potential root cause for error rates for the DynamoDB APIs in the US-EAST-1 Region. Based on our investigation, the issue appears to be related to DNS resolution of the DynamoDB API endpoint in US-EAST-1. We are working on multiple parallel paths to accelerate recovery. This issue also affects other AWS Services in the US-EAST-1 Region. Global services or features that rely on US-EAST-1 endpoints such as IAM updates and DynamoDB Global tables may also be experiencing issues. During this time, customers may be unable to create or update Support Cases. We recommend customers continue to retry any failed requests. We will continue to provide updates as we have more information to share, or by 2:45 AM.
Posted Oct 20, 2025 - 09:07 UTC
Identified
We are continuing to monitor the ongoing AWS incident affecting services in the US-East-1 region. For more information and the latest updates from AWS, please visit AWS Service Health Dashboard (https://health.aws.amazon.com).
Posted Oct 20, 2025 - 07:45 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 07:42 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 07:39 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 07:24 UTC
Investigating
We are currently experiencing a login outage affecting all data centers hosted in the US-East-1 region. This issue is caused by an ongoing AWS incident, where multiple AWS services in the region are reporting increased error rates and latency.
Posted Oct 20, 2025 - 07:19 UTC
This incident affected: Authentication, Portal, Ingestion, Wiz Defend, Sensor, Wiz CLI, and Wiz Code.